Jump to content

Avatar

Tons of Magma long note errors - Grid-locked 16th note chart...what is going on?


  • Please log in to reply
8 replies to this topic

#1 cleverest

cleverest
  • 272 posts

Posted August 10, 2020 - 05:12 AM

Is there a way to resolve this? How does this even happen?
 

I'm getting this error now in Magma MIDI TESTER, and I've checked the notes that it references... they are all grid-locked to 16th notes, as always, and they all look identical...I deleted a line and recreated to be sure, same ones come up in the errors.

I have no idea why I'm getting this in the MIDI file - when I auto-repair the file, it compiles, but then chart is totally messed up after a few seconds into the song... :-( It appears that the notes come a couple bars into the measure to quickly than the audio...

https://drive.google...iew?usp=sharing

 

Any suggestions? Thanks.



#2 TheFrisk

TheFrisk
  • 160 posts

Posted August 10, 2020 - 05:36 AM

I get this every now and then with drum notes. No clue why it does it, but my fix is to select all the notes (including animations and tom markers but not overdrive or fills!!), then right click and select "Note Properties". Where it says Length, enter either 1/32 or 1/64 and hit Ok to apply. This will resize all of the notes so their lengths are shorter. Then export the midi and try building again.



#3 cleverest

cleverest
  • 272 posts

Posted August 10, 2020 - 03:15 PM

I get this every now and then with drum notes. No clue why it does it, but my fix is to select all the notes (including animations and tom markers but not overdrive or fills!!), then right click and select "Note Properties". Where it says Length, enter either 1/32 or 1/64 and hit Ok to apply. This will resize all of the notes so their lengths are shorter. Then export the midi and try building again.

Thank you for the info. I tried this, by (choosing 1/32) and still getting this:

https://drive.google...iew?usp=sharing



#4 cleverest

cleverest
  • 272 posts

Posted August 10, 2020 - 03:19 PM

Not sure what the TWO DOWNBEATS OCCUR error on the top is either. Beat track looks normal to me as far as I can tell...but I'm new to this process...here it is (the only upbeats in the BEAT track are at the start...not sure why, but it generated that way...):

https://drive.google...iew?usp=sharing



#5 UltimatePowerBallads

UltimatePowerBallads
  • 39 posts

Posted August 10, 2020 - 03:50 PM

You’re missing a bar 13. Looks like a tempo map problem. It is an absolute a*** when that happens. I’d find it easiest to just delete all the tempo map ahead of bar 12 and do it again. It saves a lot of pain in the long-run, unless anyone else knows a faster way around.

#6 UltimatePowerBallads

UltimatePowerBallads
  • 39 posts

Posted August 10, 2020 - 03:54 PM

Also, just wanted to check; your song goes from a time signature of 4/4 to an unusual (but possible) 1/1... Is that actually right?

#7 cleverest

cleverest
  • 272 posts

Posted August 10, 2020 - 03:58 PM

Also, just wanted to check; your song goes from a time signature of 4/4 to an unusual (but possible) 1/1... Is that actually right?

It shouldn't...I tempo map it using 1:1, but then I set it back to 4/4 when doing the notes...UGH, maybe it messed up at some point and I didn't reset it to 4/4 before laying down some notes...not sure...THAT SUCKS...so sick of working on this track...I felt like I was soooo close!

Thanks for trying to help. Not sure what else I can do.

I may wait on this song, sadly.



#8 UltimatePowerBallads

UltimatePowerBallads
  • 39 posts

Posted August 10, 2020 - 04:17 PM

I’m not the best charter myself mate but from my experience; you live and you learn. I think everyone who’s made customs has had their fair share of tempo-map mess-ups before. It makes such a difference to everything when that first step has been done properly. Have a brew, take a break and go back to it later or tomorrow when you feel re-enthused and I would just re-map it. I learnt most from watching the 16-min-long Nyxyxylyth video on YouTube years ago, and I’ve had to go back and watch it several times more since to refresh my memory of how it’s done properly. You’ll get it right dude and afterward you’ll enjoy the reward of playing it. Hang in there and don’t give up.

#9 cleverest

cleverest
  • 272 posts

Posted August 10, 2020 - 05:11 PM

I’m not the best charter myself mate but from my experience; you live and you learn. I think everyone who’s made customs has had their fair share of tempo-map mess-ups before. It makes such a difference to everything when that first step has been done properly. Have a brew, take a break and go back to it later or tomorrow when you feel re-enthused and I would just re-map it. I learnt most from watching the 16-min-long Nyxyxylyth video on YouTube years ago, and I’ve had to go back and watch it several times more since to refresh my memory of how it’s done properly. You’ll get it right dude and afterward you’ll enjoy the reward of playing it. Hang in there and don’t give up.

Thanks I appreciate that...it does appear that the issue was some notes were layed down when it was set to 1/4 not 4/4, and then when those are fixed, it created little tiny notes that need deleted and recreated, but when you do that, things get out of alignment...I will have to start over, SIGH...

LESSON LEARNED!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users