Jump to content
C3 Forums

Johnny Booth - Asymmetrical (MIDI to RB2+ CON porting errors) (conversion help)

Recommended Posts

Charted this song to Guitar Hero and Rock Band 1 and played it on both with no problems 2 months ago, but I have been trying to port this to RB2 (without any ability to playtest it on there, not even with my Wii) or just make a CON file for people to play and to submit it here, but I keep getting multiple errors trying to. Stuff like channels not being exported right when I used Reaper, issues with hitting vocal notes (even for RB1), requiring channels for instruments not in the song (said it's required), and now something random about time signatures for a blank instrument channel:


"ERROR: MIDI Compiler: .../magmac3/test/....mid (PART KEYS): Multiple time signatures at measure 2 at 3:1:000"


I tried removing the "time signature" in Anvil but it confused Magma into thinking no instruments existed, and then I used the cleaner which put me in a loop of fighting the TS error.


Also, is there special information differentiating (like different header data) between the RB1/Leff-converted chart and what Reaper creates, because the RB1 chart always fails with Magma


Files and tools I'm using to make this:

MID+OGG: https://drive.google.com/uc?id=19cKKMd_5KtcZRLLNAbtL6TYtW59yRfZ5

Magma+Reaper project (including backups and mess up files for finding out the problem):


Basically all prominent tools and authoring files I could find on this site


Preview of the song (full band TAS excluding vocals):



Specifics on what I did to author (and order of trying to port) (for full information, long, how do i make a collapsible box)

- First charted in Feedback

- Converted with Leff's MIDI tool
- Reworked everything in Anvil

- Just fine to play in Rock Band 1

- Didn't work with Magma

- Tried using T&tLotW as a base to remap

- Timmy's MIDI somehow worked with Magma (IIRR)

- Hastily installed Reaper just for this

- Imported and copied notes to the C3 template

- (a bunch of stuff I probably forgot about)

- Today I went back to trying to convert this

- Readded and readjusted notes, everything

except vocals worked in RB1, surprisingly

- Vocal track is appearing after a channel's

track is over instead of being in it's own

- Vocal track's channel no. was "#7" unlike G/R/D's...?

- Shifted that back to where it should be in Anvil

- Tested in RB1, apparently only one vocal note

- Now I'm here


I might've missed something I wanted to put here since I'm getting a little distracted writing this, but I'll update this post when there's something else to mention or fix

Link to post
Share on other sites

Yeah this RPP is pretty messed up. If I start from your RBN.RPP and export that to midi, then I'm not seeing the PART KEYS error. However there are oh so many other errors instead. The drum fill lanes are for triggering overdrive, so they should only appear periodically. The overdrive markers are for building overdrive. So they can't, for example, appear during drum fills. The big rock ending markers for the other instruments (assuming you mean them to be there at all) are incorrect. If I were you, I would go track by track maybe starting with drums, and clean them up one at a time. Say mute everything but the drums and export that. You will see more comprehensible errors from Magma that you can work on fixing.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...