Jump to content

Avatar

[How-To] Playing Customs on PS4 (BETA)

ps4 tutorial

  • Please log in to reply
36 replies to this topic

#21 Synderella

Synderella
  • 12 posts

Posted December 28, 2018 - 07:57 PM

It sounds like you may be trying PKGs made with an earlier build than 0.1.141. Before that build, the customs would convert "successfully" but would not go ingame because the DTAs were written as UTF-16 instead of UTF-8. So you should try again with the latest build for those that didn't work ingame.


Thanks! I'll give it a try later then

#22 TrojanNemo

TrojanNemo

    The Programmer

  • 4,875 posts
  • Location
    Miami, Florida

Posted December 29, 2018 - 01:06 AM

Just amazing, man. Imagine what we could have accomplished if you had joined us back in 2013 when I started mashing keys on the computer and trying to churn out software stuck together with gum and zip ties. I have all my RB stuff on the Xbox so I can't really try it on my end, but I'm glad to see progress being made.



#23 chaosjaye

chaosjaye
  • 67 posts

Posted December 29, 2018 - 06:52 AM

You're asking for the impossible right there.

never hurts to wish does it:)



#24 MrPrezident

MrPrezident

    C3U Moderator

  • 930 posts
  • Location
    Nanaimo, BC, Canada

Posted December 30, 2018 - 01:57 AM

This is exciting.  Time to start collecting PS instruments.


FORUM THREAD  /  MY CUSTOMS -  Everything from ABBA to XTC
 

p89ZznR.png KhDyqmU.png

 

 


#25 Synderella

Synderella
  • 12 posts

Posted December 30, 2018 - 09:25 PM

All songs are installing and playing correctly but without sound. Not even in the preview in the songlist. The killers - Bones for example, but when I've made pkgs with 138 build song played in the menu but froze ps4 right at the beginning of the song. I think I'm on 1.3.0 version of the game. Anyway to fix this?

#26 Rocker1999

Rocker1999
  • 45 posts
  • Location
    Orlando, FL

Posted December 31, 2018 - 11:04 AM

Video tutorial is now out!  

 



#27 Synderella

Synderella
  • 12 posts

Posted December 31, 2018 - 02:13 PM

Video tutorial is now out!  
 
https://youtu.be/P-ga4FxcjZQ


Can you dump 2.13 US-update? Links wont work for those who installed game from a back-up

#28 JCLexicon

JCLexicon
  • 50 posts

Posted December 31, 2018 - 02:33 PM

Rocker and Maxton, you two are awesome!

 

If I can get my hands on a PS4 with that low a firmware, I will for sure be hopping on board.

 

Hopefully just the beginning,but miracles can indeed happen.



#29 Zurello

Zurello
  • 3 posts

Posted January 1, 2019 - 06:58 PM

Hi, thank you for the awesome tool and the nice tutorial!

Still, I have the same problem as Synderella: I tried converting 10 custom songs from customscreators.com using ForgeToolGUI (latest LibForge 0.1.157, so this shouldn't be a problem related to UTF-8), with SCEE option enabled (I'm using the EU physical disk), and then installing the 10x PKG files on my 5.05 Hen 1.8 PS4, but all the custom songs have no audio at all, not even in the preview. My game version is updated to 2.13 EU, and everything is exactly like Rocker's video tutorial.

 

What am I doing wrong here? Any help will be really appreciated!



#30 Maxton

Maxton
  • 57 posts
  • Location
    Boston

Posted January 1, 2019 - 09:39 PM

You aren't doing anything wrong, but maybe something is wrong with the customs you're using? It could also be something to do with the EU version, which I can't debug myself. Which songs are you trying, specifically?



#31 Zurello

Zurello
  • 3 posts

Posted January 2, 2019 - 09:38 AM

You aren't doing anything wrong, but maybe something is wrong with the customs you're using? It could also be something to do with the EU version, which I can't debug myself. Which songs are you trying, specifically?

 

Hi Maxton, thank you for the fast answer.

 

In the meantime, I deleted my RB4 installation and went for a fresh one (with EU 2.13 update included, of course), so I can't check the songs I previously converted, but I tried another test on my fresh-installed RB4 choosing 3 songs that should work for sure (I've seen videos of these on YT):

 

http://customscreato..._/c3-1677-r1415
http://customscreato...to-be-wild-r905
http://customscreato...ming-out-r21854

 

I got the X360 version for all 3 of them, converted with LibForge 0.1.157.0 (with the "Build for SCEE?" option on), and created the 3 pkg files:

 

EP8802-CUSA02901_00-CUSULTANSOFS8715.pkg

EP8802-CUSA02901_00-CUSTEPPENWOL5713.pkg

EP8802-CUSA02901_00-CUC3GDRIMCOM0227.pkg

 

(Also, please notice that "CUSA02901" is the proper ID for my EU version, so theoretically everything is OK.)

After that, I installed the 3 pkgs on my PS4 (5.05, Hen 1.8), booted the game, and got the "found some new songs" message: the songs are in the playlist, but again I can't hear any audio in the song previews or while playing the songs.

 

 

 

I think the EU version of the game should work too, at least judging from Rocker's video tutorial, which is using the same "CUSA02901" version I'm using.

 

I could try installing the fpkg for the US version to test if the problem is related to the EU version, but I haven't seen any fpkg with the US 2.13 update around, so I wouldn't be able to update the game.
Is the 2.13 update really required for the custom songs to work? If so, anyone has the US 2.13 update's fpkg to share?

 

Again, thank you for your help, much appreciated!


Edited by Zurello, January 2, 2019 - 09:41 AM.


#32 Maxton

Maxton
  • 57 posts
  • Location
    Boston

Posted January 2, 2019 - 01:22 PM

Ok. I think I found the issue. It's the reverse issue of what was happening in an earlier build. Your computer has localization settings that tell programs to use a comma instead of a dot by default for a decimal separator, and that's being written into the DTA files, but DTA files should always use a dot or else there will be type errors and eventually, no audio.

 

The latest build should fix that.



#33 Zurello

Zurello
  • 3 posts

Posted January 2, 2019 - 03:03 PM

Hi Maxton, it seems that LibForge 0.1.158 fixed the problem, now everything works fine, thank you!

 

While we're at this, some noobish questions:

 

1. Is the 2.13 game update really required for playing custom songs, or even the 1.00 non-updated version of RB4 would do?

2. Is there any way to remove/delete installed custom songs, other than deleting the whole game and restalling from scratch?

3. Does LibForge work only with custom songs for Xbox 360, or with other versions too (PS3, Wii, Phase Shift, etc...)?

 

Again, thank you for all your hard work on this!


Edited by Zurello, January 2, 2019 - 03:19 PM.


#34 Maxton

Maxton
  • 57 posts
  • Location
    Boston

Posted January 2, 2019 - 03:24 PM

Glad to hear that fixed your problem.

 

To answer your questions:

1. No, the update isn't required. I just tried a custom on the Blu-Ray launch version, and it did work although the album art was... sparkly

 

2. Yes, go to "Settings" -> "☆Debug Settings" -> "Game" -> "Add Content Manager" -> "Delete" -> "Rock Band 4" and from there you can choose what to delete

 

3. It only works with Xbox 360 custom songs, more specifically it is only supposed to work with RB3 customs made with MAGMA C3 edition but it should work with anything that works on RB3/X360.



#35 Synderella

Synderella
  • 12 posts

Posted January 4, 2019 - 11:48 AM

Can someone try to convert rb2 song export dlc? Or lego rock band export dlc. Will it work?

#36 Maxton

Maxton
  • 57 posts
  • Location
    Boston

Posted January 4, 2019 - 05:15 PM

Can someone try to convert rb2 song export dlc? Or lego rock band export dlc. Will it work?

 

No.



#37 Bansheeflyer

Bansheeflyer

    Moderator

  • 1,410 posts
  • Location
    The Mothball Fleet

Posted January 4, 2019 - 11:29 PM

Can someone try to convert rb2 song export dlc? Or lego rock band export dlc. Will it work?

 

No and if there is any more discussion about pirated content or delisted songs the person responsible will be banned.


As a moderator I enforce the law...in moderation.

 

My Customs
My Works in Progress






Also tagged with one or more of these keywords: ps4, tutorial

2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users