Jump to content

Avatar

Venue Camera Stuck

Venue Camera Stuck

  • Please log in to reply
9 replies to this topic

#1 InevitablEnd

InevitablEnd
  • 32 posts

Posted October 9, 2018 - 04:49 PM

I ran into an annoying bug where the venue camera seems to be stuck back in the crowd for the entire song, as seen here:

 

Usually I manually put the Practice Sessions in the Events track and let Magma's Autogeneration do it's thing, but this time it didn't seem to work. I even opened up the compiled midi and the Venue stuff seems to be there, but the camera still doesn't seem to do anything. I thought it may be since I have 3 Harmonies and only Drums/Keys, so I added in a small Guitar/Bass track for testing, but it still does it. I then thought it was the transitions of [play], [intense], and [mellow] in Vocals/Harmonies, which I haven't used before, but the camera is still stuck even after I removed them. Any thoughts?



#2 Oddbrother

Oddbrother
  • 569 posts

Posted October 9, 2018 - 05:31 PM

It's a little iffy, but from what I'm gathering, what you've provided in the video may only be happening on the Wii version of Rock Band 3 because of a keys venue issue. You might have to use MiloMod and create a patched venue.

 

This may not be a problem on the other platform versions, though. I can't confirm this as I'm not available to playtest your custom on Xbox 360.


Right and right, left and left, spin and turn, and a great big smile.

#3 InevitablEnd

InevitablEnd
  • 32 posts

Posted October 9, 2018 - 06:36 PM

Sounds good. I was actually trying to find that tool, but didn't know what it was called, so thanks for the link. I'll probably try it on my Xbox later when I have time too.

 

Edit: Used Milo to make the Drummer the singers instead of the Guitar/Bassist, but the Wii version still doesn't seem to do anything with the camera.


Edited by InevitablEnd, October 9, 2018 - 07:03 PM.


#4 Atruejedi

Atruejedi
  • 762 posts

Posted October 9, 2018 - 08:25 PM

When you convert CONs for the Wii using C3CONTools, UNCHECK under options "Convert venue during song conversion." Then convert as usual and drag the meta folder into MiloMod's window. Convert the Milo, then install as usual. This'll enable venues to work properly when a keyboardist is present. It's a godsend, and I've redownloaded and converted nearly all of my library using MiloMod in the past months.


#1 Ranked Wii Customs Player... because it's the Wii
"Like a madman laughin' at the rain" - My custom song releases
Freelancers wanted! - Works-in-progress
"One-Trick Pony" - Details of my contributions in the database!
In-Depth Eclectic Suggestions - Let's collaborate!

Vocals Charting Philosophy - Because sometimes less is more
Packing Like a Pro - The Guide for a Legit Wii Library
Last.fm Profile - Let's be snobs together.


#5 InevitablEnd

InevitablEnd
  • 32 posts

Posted October 9, 2018 - 09:05 PM

Sweet, that works, thanks!



#6 dlauthor

dlauthor
  • 99 posts

Posted April 20, 2019 - 03:50 PM

I'm getting something like this on my 360; I currently have two thumb drives with 2000+ customs on each, and one just stays on the first camera position for every song when it's plugged in (including showing nothing but the backgrounds in the "music video" settings). The other drive works fine, so I know it has to be something about the first drive -- I assume one particular song with something glitched in its data. The problem for me is isolating _which_ song. I know I could find it by trial and error ... but like I said, 2000+ songs. Even doing it efficiently, splitting the songs in half repeatedly and seeing which half has the problem, we're talking like 11 passes to isolate the problem song -- if it even is just one problem song.

 

Is there some other way to figure out which song is causing the problem, besides this kind of grunt work? Like ... god, I don't even know. But if anyone knows an easy solution to this that doesn't involve hours of transferring songs around and reloading into the game, I'd sure love to hear it.

 

(Standard disclaimer: thanks to everyone for all the incredible work on all the things; I can't believe what's available in this game now thanks to all the excellent people in this community.)



#7 StackOverflow0x

StackOverflow0x

    Wii Guy

  • 1,421 posts

Posted April 24, 2019 - 01:59 AM

I don't know much about the Xbox side of things, but is having the title updates on one of the sticks the cause of the issues? This "camera being stuck" issue has to do with trying to play RBN2-style venues on the base game. If every song on a stick is causing that issue, it could be because the game isn't updated? Certainly not a single song issue.



#8 FujiSkunk

FujiSkunk
  • 896 posts
  • Location
    Planet Houston

Posted April 24, 2019 - 03:00 PM

For RBN2-style songs, including customs, Title Update 4 is needed for venues (including cameras) to work properly on the 360.  Make sure the "problem" stick has TU4.



#9 dlauthor

dlauthor
  • 99 posts

Posted April 24, 2019 - 04:52 PM

Thanks, guys. I'll check that out tonight. I bet I deleted it when I exceeded the limit and split my songs between two sticks.



#10 dlauthor

dlauthor
  • 99 posts

Posted April 25, 2019 - 06:31 PM

Yup, that was exactly it. Thanks again, guys -- I never would have figured that out without help, and would have battered myself to bits trying to find the one bad apple in the barrel, when in fact the barrel ... um ... had no lid? I think I lost control of this metaphor.

 

Anyway, thanks!







Also tagged with one or more of these keywords: Venue, Camera, Stuck

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users