Jump to content

Avatar

Event error in Magma v3


  • Please log in to reply
14 replies to this topic

#1 Kitchenstuff

Kitchenstuff
  • 9 posts

Posted August 21, 2018 - 12:17 PM

I keep getting this error:

 

Magma: C3 Roks Edition v3.3.2
=============================
Build started at 1:17 PM
 
Starting Nemo's MIDI Validator...
Everything looks good, continuing...
 
Loading MagmaCompilerC3.exe...
Reading the archive
Project Compiler: Reading project 'C:\Users\Batuk\Downloads\Soulless 5 Rock Band\S5.rbproj'...
Project Compiler: Entering Phase 1 of 5...
Metadata Compiler: Starting...
Metadata Compiler: Done.
Project Compiler: Entering Phase 2 of 5...
MIDI Compiler: Starting...
ERROR: MIDI Compiler: (Soulless 5): Track contains multiple track name events (Soulless 5 and EVENTS)
MIDI Compiler: Done.
ERROR: Project Compiler: Midi compiler failed.
 
Anyone know whats up?


#2 Oddbrother

Oddbrother
  • 537 posts

Posted August 21, 2018 - 03:55 PM

Check to see if you have more than one Track name event in your EVENTS track. If so, keep the one named EVENTS and delete or fix the others.

bW9rlx1.png


Right and right, left and left, spin and turn, and a great big smile.

#3 Kitchenstuff

Kitchenstuff
  • 9 posts

Posted August 21, 2018 - 04:23 PM

Check to see if you have more than one Track name event in your EVENTS track. If so, keep the one named EVENTS and delete or fix the others.
bW9rlx1.png

So sorry to ask you this (I mean it, I don't like wasting people's time), but is that in Reaper, and where? I'd look right now, but I'm currently out

Sent from my SM-J320FN using Tapatalk

#4 Oddbrother

Oddbrother
  • 537 posts

Posted August 21, 2018 - 04:27 PM

When you edit in Reaper, open the EVENTS MIDI item in the MIDI Editor.

 

It will be easier to find erroneous events if you change it to event list view mode.


Right and right, left and left, spin and turn, and a great big smile.

#5 Kitchenstuff

Kitchenstuff
  • 9 posts

Posted August 21, 2018 - 07:38 PM

When you edit in Reaper, open the EVENTS MIDI item in the MIDI Editor.

 

It will be easier to find erroneous events if you change it to event list view mode.

 

This is what it looks like, but I don't see multiple events with the same name?? https://imgur.com/a/cd9zYpx



#6 Oddbrother

Oddbrother
  • 537 posts

Posted August 21, 2018 - 07:42 PM

I don't literally mean the same name, I meant more than one of the same event type. Each MIDI item should only have one Track name event it represents.

 

PART GUITAR should only have PART GUITAR for a Track name event. All other Track name events must be deleted.


Right and right, left and left, spin and turn, and a great big smile.

#7 Kitchenstuff

Kitchenstuff
  • 9 posts

Posted August 21, 2018 - 07:51 PM

huh



#8 ghostbyob

ghostbyob
  • 479 posts

Posted August 21, 2018 - 07:53 PM

Try to clean the midi or remove ilegal markers with C3CONTool or CAT.


Posted Image

#9 Kitchenstuff

Kitchenstuff
  • 9 posts

Posted August 21, 2018 - 07:58 PM

I'll give the second one a try, as I've already cleaned it, but now after removing the other track name events, it says I need a 1 type midi, not 0, and there's no option to export as that



#10 TheWay123

TheWay123
  • 129 posts
  • Location
    a place in somewhere

Posted August 21, 2018 - 08:06 PM

Do you have it set to Multitrack MIDI file



#11 Kitchenstuff

Kitchenstuff
  • 9 posts

Posted August 21, 2018 - 09:09 PM

No option to export like that

Sent from my SM-J320FN using Tapatalk

#12 Oddbrother

Oddbrother
  • 537 posts

Posted August 21, 2018 - 09:57 PM

Looking at your screenshot again, you don't appear to be using a recommended version of Reaper (4.22, 32-bit). If you switched to that and set up your authoring space around that, it will be easier for us to help you.
 
In the way you've stated that there's no option to export the MIDI of your Reaper project as multitrack (type 1), it looks like you're exporting a MIDI file from the MIDI editor section instead of the main section of your Reaper project. Just to be sure, make sure you're going to these menus here:
OcJlaFi.png
Right and right, left and left, spin and turn, and a great big smile.

#13 Kitchenstuff

Kitchenstuff
  • 9 posts

Posted August 22, 2018 - 11:10 AM

Aye, I was, but when I went to export as usual, it add the event names back, I'll update Reaper when I get back however

Sent from my SM-J320FN using Tapatalk

#14 Kitchenstuff

Kitchenstuff
  • 9 posts

Posted August 23, 2018 - 03:21 PM

Looking at your screenshot again, you don't appear to be using a recommended version of Reaper (4.22, 32-bit). If you switched to that and set up your authoring space around that, it will be easier for us to help you.
 
In the way you've stated that there's no option to export the MIDI of your Reaper project as multitrack (type 1), it looks like you're exporting a MIDI file from the MIDI editor section instead of the main section of your Reaper project. Just to be sure, make sure you're going to these menus here:
OcJlaFi.png

Ok, I've switched to 4.22, now what?



#15 Whizzer

Whizzer
  • 341 posts

Posted August 26, 2018 - 08:27 PM

After clicking 'Export project MIDI...', be sure to select 'Multitrack MIDI file' under 'Consolidate output'. REAPER will then output a type 1 MIDI file.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users