Jump to content

Avatar

Adding a short silence before song starts?


  • Please log in to reply
5 replies to this topic

#1 MoggehMan

MoggehMan
  • 5 posts

Posted August 7, 2018 - 07:55 PM

So I have started on my first custom made properly in REAPER and it's going pretty well. I exported the MIDI, used Magma to build and it was successful. Then I used C3 CON Tools to convert to Phase Shift to test (I don't have a console capable of testing) and it is working great.

 

But the problem is that the song starts straight away and there isn't any silence at the beginning, which means you would probably miss the first few notes (which is not fun). What I want is the hi-hat sound of the drummer to count in and THEN the song starts like most Rock Band customs/songs. I know it's possible, I'm just a noob at this haha!

 

Is there some event for this or something to set when the audio starts playing? Does this have to be manually added to the .WAV file (using some sort of audio editor) or is there a simpler way in REAPER?



#2 justKoda

justKoda
  • 4 posts
  • Location
    Santiago, Chile

Posted August 8, 2018 - 01:28 AM

I'll record something to show you because I can't explain it well in text. I'll come back to you when I finish.



#3 justKoda

justKoda
  • 4 posts
  • Location
    Santiago, Chile

Posted August 8, 2018 - 01:44 AM

https://youtu.be/y1dhWKhghhI



#4 doa

doa
  • 160 posts
  • Location
    Gilroy, California

Posted August 8, 2018 - 03:49 AM

I think the issue is that in Magma you are using the audio file that you imported into reaper rather than the same audio file exported from reaper.

 

You need to render (export) the audio from reaper. This will give you the additional silence that you need so that the song and the gems all line up in game. 

 

See section 14.1 of the customs tutorial here: http://d.c3universe.com/53cec8d2f2465

 

For the count in I assume that you are using the C3 Custom RB3 Template and can position the high hat sound samples before your audio as per this screenshot:

 

qjs8KQa.png

 

I managed to miss it on the screenshot but the song starts at measure 3.1.

 

My high hat samples are at 1.1, 1.3, 2.1, 2.2, 2.3 and 2.4.



#5 MoggehMan

MoggehMan
  • 5 posts

Posted August 8, 2018 - 11:09 AM

I think the issue is that in Magma you are using the audio file that you imported into reaper rather than the same audio file exported from reaper.

 

You need to render (export) the audio from reaper. This will give you the additional silence that you need so that the song and the gems all line up in game. 

 

See section 14.1 of the customs tutorial here: http://d.c3universe.com/53cec8d2f2465

 

For the count in I assume that you are using the C3 Custom RB3 Template and can position the high hat sound samples before your audio as per this screenshot:

 

qjs8KQa.png

 

I managed to miss it on the screenshot but the song starts at measure 3.1.

 

My high hat samples are at 1.1, 1.3, 2.1, 2.2, 2.3 and 2.4.

THIS is exactly what I needed! I didn't render the audio before, but now I created a brand new Magma file with it and it worked perfectly. Thanks a bunch man!



#6 doa

doa
  • 160 posts
  • Location
    Gilroy, California

Posted August 8, 2018 - 06:04 PM

Great, happy to help! :)

Sent from my VS988 using Tapatalk




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users