Jump to content

Avatar

Bad track name: 'PART REAL _KEYS_H'


  • Please log in to reply
16 replies to this topic

#1 musicalfatties

musicalfatties
  • 7 posts

Posted June 9, 2018 - 05:21 AM

Hello Everyone!

I am new to customs, and I am trying to compile my first song. magma gives me an error saying real keys hard is missing. I have not charted any pro keys. Here is the magma log: 

 
 
Found whereyougetlove...
Found PART DRUMS...
Found PART BASS...
Found PART GUITAR...
Found PART KEYS...
Found PART REAL _KEYS_H...
Found PART REAL_KEYS_M...
Found PART REAL_KEYS_E...
Found PART KEYS_ANIM_RH...
Found PART KEYS_ANIM_LH...
 
Nemo's MIDI AutoGen process started.
Added drum mix events successfully.
Nemo's MIDI AutoGen process completed.
Starting Basic EMH Check..
WARNING: PART DRUMS Hard has 0 notes.
WARNING: PART DRUMS Medium has 0 notes
WARNING: PART DRUMS Easy has 0 notes
WARNING: PART BASS Hard has the same amount or more notes than Expert.
WARNING: PART BASS Medium has the same amount or more notes than Hard.
WARNING: PART BASS Easy has the same amount or more notes than Medium.
WARNING: PART GUITAR Hard has 0 notes.
WARNING: PART GUITAR Medium has 0 notes
WARNING: PART GUITAR Easy has 0 notes
WARNING: PART KEYS Medium has the same amount or more notes than Hard.
WARNING: PART KEYS Easy has the same amount or more notes than Medium.
MIDI failed Basic EMH Check. This means the charts are most likely expert only
Refer to the log to see which chart(s) reported problems.
Ready to send files to MagmaCompiler ... hold on.
Output from MagmaCompiler follows:
Reading the archive
MIDI Compiler: Starting...
ERROR: MIDI Compiler: (MIDI FILE): bad track name: 'PART REAL _KEYS_H'
MIDI Compiler: Done.
MagmaCompiler reported some errors. Please see the log for details on what must be fixed.
 
Process completed in 0 minutes and 3 seconds.
You may drag another MIDI or just click Close to exit.
 


#2 Bansheeflyer

Bansheeflyer

    Moderator

  • 1,366 posts
  • Location
    The Mothball Fleet

Posted June 9, 2018 - 05:36 AM

You have a space between REAL and the underscore, just remove that and it should work fine.


As a moderator I enforce the law...in moderation.

 

My Customs
My Works in Progress


#3 bsbloom

bsbloom
  • 361 posts

Posted June 10, 2018 - 01:20 PM

Also, if you are not charting pro keys, then mute each pro key track. 



#4 Farottone

Farottone

    The Lean Mean Customs Charting Machine

  • Administrator
  • 6,391 posts

Posted June 10, 2018 - 03:55 PM

Also, that error comes from a very old RBN template, use the C3 template.



#5 musicalfatties

musicalfatties
  • 7 posts

Posted June 11, 2018 - 01:33 AM

Taking out the space fixed the error, but now i get this error from magma:.

ERROR: MIDI Compiler: (MIDI FILE): Could not find MIDI track authored for real_keys, possibly due to incorrect track name event

I have no notes charted in pro keys. I have keys unchecked in magma, and all of the tracks for real keys are muted.



#6 PhantomBlade8

PhantomBlade8
  • 140 posts
  • Location
    USA

Posted June 11, 2018 - 11:41 AM

Taking out the space fixed the error, but now i get this error from magma:.

ERROR: MIDI Compiler: (MIDI FILE): Could not find MIDI track authored for real_keys, possibly due to incorrect track name event

I have no notes charted in pro keys. I have keys unchecked in magma, and all of the tracks for real keys are muted.

 

This is because you didn't export the Pro Keys tracks, you can still compile the song if that's your only error.



#7 musicalfatties

musicalfatties
  • 7 posts

Posted June 11, 2018 - 11:26 PM

Thank You guys so much for helping me out with all these magma errors! I'm sorry asking so many questions, but it gives me one more error. (Hopefully the last one)

MIDI Compiler: Starting...

ERROR: MIDI Compiler: (PART VOCALS): Vocal notes exist, but no vocal phrases found
MIDI Compiler: Done.
ERROR: Project Compiler: Midi compiler failed.
Is it because i only charted them in the blue squares and not actual pitches?
 
I appreciate all the help you guys have given me!


#8 BornGamerRob

BornGamerRob
  • 332 posts
  • Location
    California

Posted June 12, 2018 - 03:55 AM

Is it because i only charted them in the blue squares and not actual pitches?

 
No idea what that means, but I'm going to assume you charted them unpitched. Even so, as the compiler stated, you need vocal phrases. Vocal phrases are straight bars that encompass your phrase. They are placed in the area near the top of the vocal chart labeled Phrase Marker. They should resemble the photo below (the purple line is a phrase marker that covers the phrase). You have to place those over every phrase.

42028548814_27aba9b015_z.jpg


_________________________________________________
 
Check out my video playlists: YOUTUBE | VIMEO (superior)


#9 bsbloom

bsbloom
  • 361 posts

Posted June 12, 2018 - 12:13 PM

If you have only one vocal track, phrase markers are easy.  Each of your phrases should start out with a capitalized word.  Place a @ before each such word.  This tells CAT that these begin a phrase.  Then use CAT to put in phrase markers.  CAT will correctly place each phrase marker, and remove the @ symbols.  Done.

 

I suspect this will work when you have harmony tracks, but I haven't figured out how to get CAT to do phrase markers for harmony tracks, so I put those in by hand.



#10 Farottone

Farottone

    The Lean Mean Customs Charting Machine

  • Administrator
  • 6,391 posts

Posted June 12, 2018 - 02:52 PM

If you have only one vocal track, phrase markers are easy.  Each of your phrases should start out with a capitalized word.  Place a @ before each such word.  This tells CAT that these begin a phrase.  Then use CAT to put in phrase markers.  CAT will correctly place each phrase marker, and remove the @ symbols.  Done.

 

I suspect this will work when you have harmony tracks, but I haven't figured out how to get CAT to do phrase markers for harmony tracks, so I put those in by hand.

 

Same:

 

7xvXv9L.png

 

Select Vocals and Harmonies and it will do all in one pass.



#11 musicalfatties

musicalfatties
  • 7 posts

Posted June 13, 2018 - 01:16 AM

Thank you guys!

I had some more vocal errors, but I was able to fix them by looking on the RBN Documents. 

The song compiled, and I was able to test it in the game.

I have to make some corrections in Reaper, then it should be ready to go.

If I encounter any more errors (Hopefully i don't) that I won't be able to fix on my own or by reading the documents, I will post them here.

Thanks everyone for helping me!

 



#12 musicalfatties

musicalfatties
  • 7 posts

Posted June 14, 2018 - 12:56 AM

Hey everyone I compiled the song, and the game says the song has no vocals.

In magma I have vocals checked. and made tracks called blank.wav in a separate reaper project.
Do i need to change my tracks from blank tracks to real tracks?
 
Here are the images of what the game shows me, and my tracks in magma. 
 
 
Thank You!

 



#13 Atruejedi

Atruejedi
  • 629 posts

Posted June 18, 2018 - 07:27 PM

You probably need to refresh your library, now that you've added vocals. That's how it works on the Wii. So remove your song and then re-add it with the songs.dta that reflects that the song does, indeed, have vocals.


#1 Ranked Wii Customs Player... because it's the Wii
"Like a madman laughin' at the rain" - My custom song releases
Freelancers wanted! - Works-in-progress
"One-Trick Pony" - Details of my contributions in the database!
In-Depth Eclectic Suggestions - Let's collaborate!

Vocals Charting Philosophy - Because sometimes less is more
Packing Like a Pro - The Guide for a Legit Wii Library
Last.fm Profile - Let's be snobs together.


#14 BornGamerRob

BornGamerRob
  • 332 posts
  • Location
    California

Posted June 20, 2018 - 05:44 AM

If you compiled it once without vocals, you'll now have to give it a new song id. every time you add a new track, you need to give it a new id upon compilation.


_________________________________________________
 
Check out my video playlists: YOUTUBE | VIMEO (superior)


#15 musicalfatties

musicalfatties
  • 7 posts

Posted June 26, 2018 - 12:10 AM

If you compiled it once without vocals, you'll now have to give it a new song id. every time you add a new track, you need to give it a new id upon compilation.

It ended up being the xbox that was the problem, the song cache was corrupted.



#16 musicalfatties

musicalfatties
  • 7 posts

Posted June 26, 2018 - 12:12 AM

This may be a dumb question, but where is the option in CAT to autogenerate Easy, Medium, and Hard? I'm not able to find it in the scripts. 



#17 Whizzer

Whizzer
  • 346 posts

Posted June 26, 2018 - 01:46 AM

This may be a dumb question, but where is the option in CAT to autogenerate Easy, Medium, and Hard? I'm not able to find it in the scripts. 

Look for reductions.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users