Jump to content

Avatar

Newbie Questions - Calibration and Broken Songs


  • Please log in to reply
5 replies to this topic

#1 krkoets11

krkoets11
  • 3 posts

Posted February 22, 2018 - 09:55 PM

Hello everyone!  I'm new to the forums and the world of customs, so hopefully my questions aren't too stupid.

 

1) I've been having trouble calibrating Rock Band 3 (Xbox 360) to play custom songs.  I have solid calibration numbers for the base game and official DLC, but the customs that I have played (mostly Mastodon, Dream Theater, and DragonForce) are all off.  I've seen the legendary Tommy Gun calibration video, so I know how to calibrate, but I just can't get numbers that work for the customs.  Cranking the numbers to the extreme positive or negative doesn't even seem to have an effect.  Is this a typical problem?  Any tips?  Note: this is mostly a problem with drums, guitar seems to calibrate ok.

 

2) I've downloaded a few dozen songs and the only one that doesn't work is Disciples of Babylon, both single and double pedal versions.  The song appears in Quickplay with instrument difficulties, song length, audio preview, etc.  The only thing off is the album art - it appears just blank white.  When I try to play the song, I get the "song data is unavailable" message.  What might be the problem, and is it fixable?

 

I'd appreciate any help you can provide.



#2 onyxite

onyxite
  • 54 posts

Posted February 23, 2018 - 02:19 AM

It looks like Disciples of Babylon has the same issue this other song had. I've messaged the author to get it fixed.

To answer your other question, you definitely shouldn't need different calibration numbers for customs in general as opposed to official content. However, specific songs could be poorly synced to the audio. Do you have an example?



#3 Fat Ha1p3rt

Fat Ha1p3rt
  • 391 posts
  • Location
    Michigan

Posted February 23, 2018 - 03:49 AM

Many of the songs in the database that originated as single-instrument customs (typically guitar only) were converted from other games like Frets on Fire. A lot of these songs tend to have mediocre tempo maps, or no map at all. A lot of those songs just have 1 single tempo marker at the start of the song, so the song will slowly become out of sync as it goes on. Since it sounds like you've calibrated correctly, I'd go out on a limb and chalk this up to poor or non-existent tempo mapping.



#4 krkoets11

krkoets11
  • 3 posts

Posted February 23, 2018 - 06:51 PM

To answer your other question, you definitely shouldn't need different calibration numbers for customs in general as opposed to official content. However, specific songs could be poorly synced to the audio. Do you have an example?

 

Just about every Dream Theater and Mastodon song is off, but by varying degrees.  The worst is Assassin by Muse.  I can play guitar just fine after calibrating, but I can't hit a single note on drums.  I don't know why such a discrepancy exists between the two instruments.



#5 SynthStreaks

SynthStreaks
  • 129 posts

Posted February 23, 2018 - 07:15 PM

I know there are a lot of songs like what Fat Ha1p3rt said where they're converted from Frets on Fire and they just have the most atrocious tempo maps you could think of sometimes.

 

There's songs like the ones that were charting from NothingChanges in which the charting was so bad, most of his songs were unplayable (most notably At Doom's Gate). Not trying to bash him or anything, but it's just sad to see charting be that bad. There's also a few GH conversions that seem fine until the drum chart is looked at. I could understand what krkoets means, because I know that the Vicarious conversion from GH has a very uncomfortable drum chart to play. The notes have pretty much been moved into 16th places or so, leaving a lot of triplets to go off in places.


epic gamer moment

 

Customs thread: http://customscreato...ms-as-of-42317/


#6 Kylr0y

Kylr0y
  • 61 posts
  • Location
    Tennessee

Posted February 23, 2018 - 08:34 PM

I have found it helpful to delete your song cache file in your rb directory after installing any new or mainly updated or same titled songs from different authors

 

i had the same problem with the white album art and song not working and when i deleted the cache file the worked fine

 

just delete it often as it is generated every time you load the game, that is if it doesnt exist

if it does it only adds new songs to the list but for some reason songs with the same name will be corrupted sometimes


Kylr0y





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users