Jump to content

Avatar

Having trouble in Magma


  • Please log in to reply
8 replies to this topic

#1 Jordan

Jordan
  • 143 posts

Posted June 28, 2016 - 09:19 AM

So I charted drums for my song so my friend could try it out. Went to compile and I keep getting this strange error.

Magma: C3 Roks Edition v3.3.2
=============================
Build started at 4:18 AM
 
Starting Nemo's MIDI Validator...
Everything looks good, continuing...
 
Nemo's MIDI AutoGen process started.
Added drum mix events successfully.
Nemo's MIDI AutoGen process completed.
 
Loading MagmaCompilerC3.exe...
Reading the archive
Project Compiler: Reading project 'C:\Users\Aegis\Desktop\CalltoArmsDrums.rbproj'...
Project Compiler: Entering Phase 1 of 5...
Metadata Compiler: Starting...
Metadata Compiler: Done.
Project Compiler: Entering Phase 2 of 5...
MIDI Compiler: Starting...
ERROR: MIDI Compiler: (PART DRUMS): MIDI events at [92:4:120] after the end event at [92:4:000]
ERROR: MIDI Compiler: (MIDI FILE): Could not find MIDI track authored for guitar, possibly due to incorrect track name event
ERROR: MIDI Compiler: (MIDI FILE): Could not find MIDI track authored for bass, possibly due to incorrect track name event
ERROR: MIDI Compiler: (MIDI FILE): Could not find MIDI track authored for vocals, possibly due to incorrect track name event
MIDI Compiler: Done.
ERROR: Project Compiler: Midi compiler failed.
 
There doesn't seem to be a problem at the 92nd measure in my song so I don't know what's going on...unless it means something else. That is also at about 4:04 in my song and at the same time, when I drag/drop my midi file into Song Analyzer, it says the length is 4:04, the song is actually about 5:11 (as per the .wav). I assume these 2 things have something to do with each other...


#2 Chips

Chips
  • 421 posts

Posted June 28, 2016 - 02:16 PM

You have to adjust your [end] event so that it's positioned at the end of the song. I believe this is stated in the beginner's tutorial. Go into reaper, open the events track, and look for the [music end] and [end] text events at the bottom. Move them to the end of the song, with the [music end] event being positioned just before [end]. Magma won't compile if you have any notes charted after the [end] event.



#3 Jordan

Jordan
  • 143 posts

Posted June 28, 2016 - 03:58 PM

Ah, thank you. Now all I'm getting is the

 

ERROR: MIDI Compiler: (MIDI FILE): Could not find MIDI track authored for guitar, possibly due to incorrect track name event
ERROR: MIDI Compiler: (MIDI FILE): Could not find MIDI track authored for bass, possibly due to incorrect track name event
ERROR: MIDI Compiler: (MIDI FILE): Could not find MIDI track authored for vocals, possibly due to incorrect track name event
 
I don't really know what could be causing this. I have a note at the start of every difficulty for every track.


#4 raynebc

raynebc
  • 244 posts

Posted June 28, 2016 - 05:17 PM

Those tracks may be named incorrectly.

#5 Spindoctor

Spindoctor
  • 1,196 posts
  • Location
    British Columbia Canada

Posted June 28, 2016 - 05:53 PM

If I read this right why would you try to compile a drums only song with guitar & bass & vocals? Uncheck them in magma unless you have actually charted more than one note.

Links to all songs are in the Customs database.

 

Rock with the Doc at c3Universe

 

"Music can change the world because it can change people"  

Bono


#6 Jordan

Jordan
  • 143 posts

Posted June 28, 2016 - 06:48 PM

Those tracks may be named incorrectly.

I'm using the C3 template, they should already be named correctly.

 

And oh, I was not aware I could just uncheck them.



#7 Jordan

Jordan
  • 143 posts

Posted June 29, 2016 - 02:57 AM

Eh, I guess it doesn't matter.

 

Song is on the database and in my WIP thread for anyone that wants to try it out! It is not finished yet but the drums are playable.



#8 DemonUnicorns

DemonUnicorns
  • 714 posts
  • Location
    Shangri-la

Posted June 30, 2016 - 02:10 AM

It is possible that you have the guitar/bass/vocal tracks muted in reaper.

#9 DashRetro

DashRetro
  • 27 posts
  • Location
    Minnesota, US

Posted March 24, 2018 - 03:38 AM

It is possible that you have the guitar/bass/vocal tracks muted in reaper.

 

I was just having this same problem almost two years later, and this was the solution; the MIDI tracks were muted.  Thanks!


I stream on Twitch! https://twitch.tv/dashretro





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users