Jump to content

Avatar

[How-To] Playing Customs on Wii


  • Please log in to reply
2783 replies to this topic

#2741 EuroMIX

EuroMIX
  • 89 posts

Posted June 27, 2018 - 04:26 PM

hi it's me again, i have another problem but not the same as last time (that problem was a filename error, stupid mistake thats my fault). this time im having trouble with resetting the cache.  on wiixplorer i navigate to the folder, but i wasn't able to find the data folder (theres a file named data, though). can anyone help?

 

Is this on the original Wii or the Wii U's virtual Wii (vWii)?



#2742 drenal

drenal
  • 7 posts

Posted June 27, 2018 - 05:23 PM

 

Is this on the original Wii or the Wii U's virtual Wii (vWii)?

im on my wii u



#2743 EuroMIX

EuroMIX
  • 89 posts

Posted June 28, 2018 - 03:59 AM

You (apparently) can't delete the MSTORE.vff file directly using WiiXplorer on a vWii like you can on an original Wii. You'll need to follow what I've quoted below:

 

 

I actually worked it out in the meantime; use SGM to extract the save, put the SD card into a PC and navigate to the extracted save, delete MSTORE.vff, put SD card back into Wii, use SGM to install save, load game and the cache will reload.

 

I tried editing the MSTORE.vff directly with a hex editor, however it looks like it can be super tricky to try, as my attempt caused the game to lock up. I'm guessing you can only make minor edits that don't change the overall file size, or must really know what you're doing.

 

SGM stands for Save Game Manager, which is a homebrew app that lets you extract and install saves to your system. I'd recommend at least keeping a backup of your most recent save, just in case, and remember to extract your save again if you make any further progress in the game else you'll either lose progress using an older save, or worse. Just make sure when you reset your cache this way you extract a fresh copy of your save each time and back it up.



#2744 drenal

drenal
  • 7 posts

Posted June 28, 2018 - 05:55 PM

You (apparently) can't delete the MSTORE.vff file directly using WiiXplorer on a vWii like you can on an original Wii. You'll need to follow what I've quoted below:
 

 
SGM stands for Save Game Manager, which is a homebrew app that lets you extract and install saves to your system. I'd recommend at least keeping a backup of your most recent save, just in case, and remember to extract your save again if you make any further progress in the game else you'll either lose progress using an older save, or worse. Just make sure when you reset your cache this way you extract a fresh copy of your save each time and back it up.

Since I don't have my laptop on me, is it possible for me to install the Homebrew with WiiLoad, then use Wiixplorer to delete the files directly from the wii u?

#2745 uxxiha

uxxiha
  • 2 posts

Posted June 30, 2018 - 11:49 PM

Hello, i need help with the ng_id.txt and common-key. Do I need to BUY a original DLC for the "ng_id.txt"? And the common-key some one have a link for that? hope can help me, regards.



#2746 Alternity

Alternity
  • 795 posts

Posted July 1, 2018 - 12:00 AM

There are 20 free songs from the store, you can download any one of these for the ng_id. Unfortunately we cannot share common-key, but you should be able to find this quite easily through google.



#2747 uxxiha

uxxiha
  • 2 posts

Posted July 1, 2018 - 04:21 PM

Tnx, I just installed the wads that le you get all the songs from the netwrok in the wii, I never finded the free songs... i put the BINs of the official DLCs in the SD And the convert CON files tool says that: "thats not a valid BIN file: incorrect header" what i can do?



#2748 StackOverflow0x

StackOverflow0x

    Wii Guy

  • 1,376 posts

Posted July 6, 2018 - 02:27 AM

Hello, i need help with the ng_id.txt and common-key. Do I need to BUY a original DLC for the "ng_id.txt"? And the common-key some one have a link for that? hope can help me, regards.

The initial setup guide suggests you to backup your NAND. When you do this, you should have the ng_id in the keys.bin file.



#2749 doa

doa
  • 174 posts
  • Location
    Gilroy, California

Posted July 6, 2018 - 07:37 PM

I'm trying to get a custom working in Dolphin. 

 

I put my custom through the Wii Converter and named the folders:

 

001_00000001_customs_meta

002_00000002_customs_song

 

In the meta folder songs.dta  I have "dlc/sZAE/001/ …"

 

I copied the two folders over to another folder with the RB3WiiPackTool and ran it to create packdlc.bat. 

 

Packdlc.bat produced 00000001.app and 00000002.app. 

 

I copied both of these files to C:\Program Files\Dolphin\Sys\Wii\title\00010005\735a4145\content

 

I then ran Dolphin - but my custom does not show up. 

 

I've looked at this guide and ATrueJedi's guide for Wii - I don't see what I missed or did wrong above?



#2750 Alternity

Alternity
  • 795 posts

Posted July 6, 2018 - 07:45 PM

You need to have the slots unlocked, essentially need to find wad files for them. Sent a PM with info I can't share here.



#2751 Teffy

Teffy
  • 9 posts

Posted July 6, 2018 - 10:18 PM

I'm getting the "content cannot be restored" error and I don't know how to fix it. As far as I'm aware my meta folder is correct and my song folder is there. What should I do to fix this?

 

EDIT: I'm on a real Wii and I'm using SD card storage.



#2752 seg45

seg45
  • 31 posts

Posted July 7, 2018 - 12:14 AM

Are you loading up the game with USB Loader GX or something similar?

#2753 Teffy

Teffy
  • 9 posts

Posted July 7, 2018 - 02:27 AM

Are you loading up the game with USB Loader GX or something similar?

I'm using cfg. My disk drive is broken so I can't use physical games.



#2754 Alternity

Alternity
  • 795 posts

Posted July 7, 2018 - 02:46 AM

Did you change the path in the dta file corresponding to the meta slot you're using?



#2755 Teffy

Teffy
  • 9 posts

Posted July 7, 2018 - 02:55 AM

Did you change the path in the dta file corresponding to the meta slot you're using?

Yes. It says  "dlc/sZFE/054/content/songs/listen/listen", and my meta folder is 54.



#2756 StackOverflow0x

StackOverflow0x

    Wii Guy

  • 1,376 posts

Posted July 7, 2018 - 05:55 PM

Yes. It says  "dlc/sZFE/054/content/songs/listen/listen", and my meta folder is 54.

Please use content generation sZGE, since it does not contain paid DLC in it. I include the WAD for sZGE, which you'll need to install for customs to work. Also make sure common-key and ng_id values are correct.



#2757 Teffy

Teffy
  • 9 posts

Posted July 7, 2018 - 07:30 PM

Please use content generation sZGE, since it does not contain paid DLC in it. I include the WAD for sZGE, which you'll need to install for customs to work. Also make sure common-key and ng_id values are correct.

I switched to the sZGE pack and installed the wad, but now the song doesn't even show up in the list. I'm pretty sure my common-key is fine, but I could be wrong.



#2758 Alternity

Alternity
  • 795 posts

Posted July 7, 2018 - 08:25 PM

Try resetting your cache.



#2759 Teffy

Teffy
  • 9 posts

Posted July 7, 2018 - 08:44 PM

Try resetting your cache.

I can't. I'm currently in nand:/title/00010000/535a4245 and there are two files: content and data. Neither are folders.



#2760 Koopa2215

Koopa2215
  • 93 posts
  • Location
    Some where you're not

Posted July 22, 2018 - 01:17 AM

Is the link for the DLC-packer down or is it just me?


AROUND MY HEAD




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users