Jump to content

Avatar

[How-To] Playing Customs on Wii


  • Please log in to reply
2736 replies to this topic

#2721 giravolt

giravolt
  • 10 posts

Posted June 11, 2018 - 03:24 PM

do you have an idea please?

thanks



#2722 EuroMIX

EuroMIX
  • 86 posts

Posted June 11, 2018 - 04:06 PM

The DLC is split into different content generations, so sZAE/sZAP is broken down into "sZ" which is the game, "A" the generation, and "E/P" the region.

 

sZAP is the first PAL DLC generation, with nearly every other continuing chronologically (sZBP, sZCP, etc). Generation F was for Rock Band Network songs, but only partially used, that's why you can use the later slots without conflicting with official DLC. Stack, the OP, has also been able to enable the use of a few other content generations such as G and H that weren't used at all.

 

The main packing folder listed is for the F generations though, and you should probably start with that one. sZAE/sZAP was just an example, the point is you should always make sure when these DLC generations come up that sZ[whatever]E is sZ[whatever]P in order for customs to work on PAL region systems. This includes the DTA files, which you can open and edit with programs like Notepad on Windows.

 

Whatever you pack should be placed within a folder on the SD card related to the respective generation, so sZFP should be in the sZFP folder; if there isn't one, create it. The folders should be in "private/wii/data".

 

Does that make sense?



#2723 giravolt

giravolt
  • 10 posts

Posted June 11, 2018 - 04:54 PM

yes it is enough clear i think, thanks (even if it is a little difficult in english)... but is this why i have an error message on the menu of the game? i've tried with A sZAP and sZFP, and i have both the error message.

thanks



#2724 Alternity

Alternity
  • 756 posts

Posted June 11, 2018 - 11:18 PM

The license message probably means you didn't install the needed WAD file for the generation you are trying to use. C3 does not provide the WAD file for the ones you are trying to use since they are official generations. I suggest trying one of the custom ones, they will include a WAD file that you can install using any WAD manager, you are looking for error -1022 instead of a normal success. If you still want to use the official generations you will have to find those WAD files elsewhere. (google is your friend)



#2725 giravolt

giravolt
  • 10 posts

Posted June 12, 2018 - 01:11 PM

Great...thanks everybody now everything is working!! but still one question, on the custom songs database 90% of the songs are only for xbox...is there a way to play them on wii please?



#2726 EuroMIX

EuroMIX
  • 86 posts

Posted June 12, 2018 - 02:29 PM

If the custom's audio is single-track, you can just convert it with C3 CON Tools Wii Converter option, edit the resulting folders so that the numbers and content generation you want to pack in is correct, then pack it with that generation's DLC packer, e.g. sZFP.

 

You can also check the legacy database for Wii-compatible versions of customs for songs that may not be single-track (multi-tracked ones).

 

Whether multi-tracked customs will work on the Wii or not depends on several factors:

  1. The song folder is less than 40MB in size.
  2. The number of audio channels is 10 or less (most shoot for 8/9 to be sure).

2. is probably the biggest problem as the more instruments the more audio channels, made even worse if there are keys as well. If the MOGG audio file is unprotected (not encrypted) then it's possible to compress the channels down into a BIK file, but this takes its own set of knowledge and work to do.



#2727 Alternity

Alternity
  • 756 posts

Posted June 12, 2018 - 11:06 PM

Why 10? 12 seems to work fine for me.

 

I recall some songs working for me and not for others on real wii... I wonder what causes this.



#2728 EuroMIX

EuroMIX
  • 86 posts

Posted June 13, 2018 - 12:49 AM

Any more than 10 channels risks causing the game to lag in my experience.

 

I'll assume the Wii can only handle so many concurrent audio channels at once, especially dynamic ones.



#2729 Alternity

Alternity
  • 756 posts

Posted June 13, 2018 - 12:59 AM

For me it really is anything over 12, so it looks like not every Wiis reacts the same way.... that's interesting.



#2730 giravolt

giravolt
  • 10 posts

Posted June 13, 2018 - 03:41 PM

Sorry but can we use the hexadecimal 058_0000003A after the 057_00000039 please? or it must only with numbers?

thanks



#2731 EuroMIX

EuroMIX
  • 86 posts

Posted June 13, 2018 - 05:27 PM

Yeah you need to convert the numbers to hexadecimal for the latter half. So 058 would be 058_0000003A, not 058_00000040.

 

I had to learn this myself when I started due to being unfamiliar with hexadecimal.



#2732 Atruejedi

Atruejedi
  • 550 posts

Posted June 14, 2018 - 07:33 PM

My spreadsheet has all the hexadecimal info you'll need, hopefully.

 

https://www.dropbox....ustoms.ods?dl=0


#1 Ranked Wii Customs Player... because it's the Wii
"Like a madman laughin' at the rain" - Custom song releases
Freelancers wanted! - Works-in-progress
"One-Trick Pony" - Details of my contributions in the database!
In-Depth Eclectic Suggestions - Let's collaborate!
Packing Like a Pro - The Guide for a Legit Wii Library
Last.fm Profile - Let's be snobs together.


#2733 seg45

seg45
  • 21 posts

Posted June 14, 2018 - 11:53 PM

I have some rba files for some songs(technically it's one large song in a bunch of parts). I turned them into con files with the con converter on the C3 Con tools. I when I try packing them into bin files I get:
Errors found:
382_0000017E_DreamTheater-SixDegreesPt._meta Path is /000/content/should be /382

#2734 Alternity

Alternity
  • 756 posts

Posted June 14, 2018 - 11:56 PM

You need to change /000/ to /382/ in the DTA file. You possibly need to change sZAE to whatever generation you are using too.



#2735 seg45

seg45
  • 21 posts

Posted June 15, 2018 - 02:05 AM

Yeah i did that and still get that error.

#2736 StackOverflow0x

StackOverflow0x

    Wii Guy

  • 1,366 posts

Posted June 18, 2018 - 04:48 AM

I have some rba files for some songs(technically it's one large song in a bunch of parts). I turned them into con files with the con converter on the C3 Con tools. I when I try packing them into bin files I get:
Errors found:
382_0000017E_DreamTheater-SixDegreesPt._meta Path is /000/content/should be /382

Can you give a little more details on what's happening for you to get this error? The suggestion Alternity gave should work, but I need more info to find out why that didn't work.



#2737 seg45

seg45
  • 21 posts

Posted June 19, 2018 - 02:30 AM

Well i changed it to the correct number and correct generation. The thing is this really only happens with con files that were originally rba files.




3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users