Jump to content

Avatar

[How-To] Playing Customs on Wii


  • Please log in to reply
2735 replies to this topic

#2701 Aadc

Aadc
  • 8 posts

Posted May 27, 2018 - 12:16 AM

@StackOverflow0x
Is there's a way/hack/codes to force all instrument mode appear for vocal (1-3 mics) only? as my sister only use rb3 for karaoke & doesn't need scoring

Thank you

#2702 StackOverflow0x

StackOverflow0x

    Wii Guy

  • 1,366 posts

Posted May 27, 2018 - 01:05 AM

Does anyone have instructions on how to use SaveGame Manager GX to delete the cache? I would like to ensure that I do it correctly.

The idea is if you back up your save, it should come with the cache. Then you can delete the cache from it and reload your save. Can I see what it looks like?

 

 

The midi file size is 1,452 KB

Interesting that this would never work on Wii. It could explain why it never got any of the super-long songs. Could you send this one to me to see if I can figure out a way to load it?

 

@StackOverflow0x
Is there's a way/hack/codes to force all instrument mode appear for vocal (1-3 mics) only? as my sister only use rb3 for karaoke & doesn't need scoring

Thank you

What do you mean by this? You want All Instruments Mode with only a mic player? Could you get the same effect you're looking for with the autoplay cheat?



#2703 EuroMIX

EuroMIX
  • 86 posts

Posted May 27, 2018 - 01:56 PM

The idea is if you back up your save, it should come with the cache. Then you can delete the cache from it and reload your save. Can I see what it looks like?

 

I actually worked it out in the meantime; use SGM to extract the save, put the SD card into a PC and navigate to the extracted save, delete MSTORE.vff, put SD card back into Wii, use SGM to install save, load game and the cache will reload.

 

I tried editing the MSTORE.vff directly with a hex editor, however it looks like it can be super tricky to try, as my attempt caused the game to lock up. I'm guessing you can only make minor edits that don't change the overall file size, or must really know what you're doing.

 

Also, I thought midi file size only really mattered for upgrades in the meta folder?



#2704 Alternity

Alternity
  • 753 posts

Posted May 27, 2018 - 03:50 PM

The meta folder filesize limit is 500kb for the SD card method only. If you're using an emunand these songs works fine on real Wii.



#2705 StackOverflow0x

StackOverflow0x

    Wii Guy

  • 1,366 posts

Posted May 28, 2018 - 02:14 AM

Oh right, what was I thinking. The 500KB limit is for meta folders. This is the song folder.

I just tried it and it seems the game doesn't like MIDIs larger than 1MB. I was able to get it down to 900KB and that worked. I did this by deleting the venue track and using MiloMod to move the venue there. Then I removed the Pro Guitar and Pro Bass upgrades, which can possibly be moved to a separate upgrade and should still work.



#2706 drenal

drenal
  • 4 posts

Posted June 7, 2018 - 05:56 AM

hello, i am new to this community and i would like some help with this. i have followed all the instructions, and at the part where it generates the .bin and .app files, the .bin files are named 000.bin and 054.bin. so i put them on my sd card and put it in my wii u, and when i go to the song list, it states that some add-ons are corrupted. the only add-ons available are the ones i downloaded from the rock band store. then, when i put my sd card back in my computer, i find that 054.bin has been deleted. if it helps, i am not using the NAND method.



#2707 EuroMIX

EuroMIX
  • 86 posts

Posted June 7, 2018 - 02:49 PM

Did you obtain the correct ng_id, common key, and change the 000_00000000 to the correct numbers? In the case of 054 and 055 (did you remember to set this one up properly as well?) this would be 054_00000036 and 055_00000037. I also recommend compiling with RB3WiiCustomsManager because it'll tell you if the numbers are wrong, and what they should be. It'll also tell you if anything else in your packing folder looks wrong; just put a copy in every packing folder you have and run it, plus you can use it instead of the old method to pack BINs.



#2708 drenal

drenal
  • 4 posts

Posted June 7, 2018 - 06:18 PM

Did you obtain the correct ng_id, common key, and change the 000_00000000 to the correct numbers? In the case of 054 and 055 (did you remember to set this one up properly as well?) this would be 054_00000036 and 055_00000037. I also recommend compiling with RB3WiiCustomsManager because it'll tell you if the numbers are wrong, and what they should be. It'll also tell you if anything else in your packing folder looks wrong; just put a copy in every packing folder you have and run it, plus you can use it instead of the old method to pack BINs.


For the ng_id I got a free song from the store, and for the common key I checked the size, if those aren't the problems then I'll go over my customs again when I can and see if anything else is the problem.

#2709 drenal

drenal
  • 4 posts

Posted June 7, 2018 - 08:47 PM

Ok so I got home and I recompiled the customs with rb3wiicustomsmanager, it said the common key was good, and that the files were named correctly, so I used it to compile the customs and it only gave me one .bin called 054.bin. So I put it on my SD card, and once again I get the corrupted songs message...

edit: ok, i think i made a noob mistake, i had multiple customs all under the 054 and 055 names. so i removed all but one and it seems to have worked. now my question is, how do i add multiple customs at once in different slots?



#2710 EuroMIX

EuroMIX
  • 86 posts

Posted June 7, 2018 - 09:10 PM

You should get at least two BINs for each song(s) you add because the game splits them into meta and song folders/APPs/BINs. If you're not getting both 054 and 055, then something must be set up wrong. Double-check you have the song folder set up for 055 and everything inside it looks okay.



#2711 drenal

drenal
  • 4 posts

Posted June 7, 2018 - 09:31 PM

You should get at least two BINs for each song(s) you add because the game splits them into meta and song folders/APPs/BINs. If you're not getting both 054 and 055, then something must be set up wrong. Double-check you have the song folder set up for 055 and everything inside it looks okay.

I checked and everything seems ok, so i thought that maybe i should rename the files to another slot, so i did and when i loaded the game up it didnt say anything about corrupt files but i can't find the song in the list. i made sure to edit the songs.dta file too. 



#2712 giravolt

giravolt
  • 10 posts

Posted June 8, 2018 - 07:29 AM

hello please help me (in french if it is possible)...i've tried but i didn't quite understand...especially the part with the RB3wiipacktool, i've taken a ng_id.txt (from another song downloades on RB3 strore) and the common-key i can't find it (i've found one but with more than 16 digit is it possible? ebe42a225e8593e448d9c5457381aaf7

after that i cannot manage to have Bin files for my sd card i only get

Creating batch files...

Processing file 052_00000034_nlfr_meta

Processing file 053_00000035_nlfr_song

 

packdlc.bat Batch File prepared!

 

What did i miss please?

thanks



#2713 giravolt

giravolt
  • 10 posts

Posted June 8, 2018 - 07:53 AM

sorry i've had succeed about the bin files..it is ok..but no songs appear when i tried to play.

I've place the 2 folders of my new song (with the change of numbers 054_00000036 and 055_00000037) into the RB3WII dlc packer folder..i've run the "packdlc" file...4 files appeared 2 App and 2 bin. i've placed the 2 bins on my SDcard into the created folder sZFE/54.

But what do i have to do with the 2 files .app.?

What can be the reasons , the songs won't appear in my game please?



#2714 StackOverflow0x

StackOverflow0x

    Wii Guy

  • 1,366 posts

Posted June 8, 2018 - 01:46 PM

sorry i've had succeed about the bin files..it is ok..but no songs appear when i tried to play.

I've place the 2 folders of my new song (with the change of numbers 054_00000036 and 055_00000037) into the RB3WII dlc packer folder..i've run the "packdlc" file...4 files appeared 2 App and 2 bin. i've placed the 2 bins on my SDcard into the created folder sZFE/54.

But what do i have to do with the 2 files .app.?

What can be the reasons , the songs won't appear in my game please?

Did you mod your console as mentioned in the first page? That means install all the WAD files and run the game through a USB loader with IOS249. You said you'd prefer help in French, does that mean you're in Europe?



#2715 giravolt

giravolt
  • 10 posts

Posted June 8, 2018 - 03:31 PM

the first link doesn't work "this comprehensive guide" so i've just download wiixplorer and place the unzip folder in the app folder...but maybe there was something else to do? and yes i am in europe, it can't work?

thanks



#2716 giravolt

giravolt
  • 10 posts

Posted June 8, 2018 - 03:34 PM

and i use usb loader GX to play the game



#2717 StackOverflow0x

StackOverflow0x

    Wii Guy

  • 1,366 posts

Posted June 10, 2018 - 01:34 AM

the first link doesn't work "this comprehensive guide" so i've just download wiixplorer and place the unzip folder in the app folder...but maybe there was something else to do? and yes i am in europe, it can't work?

thanks

Oh, the guide is finally gone? Here is the guide archived.

For using a European version of the game, you should be using the PAL packer files. This means the generation you should be using is sZFP, not sZFE.



#2718 giravolt

giravolt
  • 10 posts

Posted June 11, 2018 - 07:37 AM

Hey thanks , i just have to replace the name of the folder into sZFP or is it more complicated than that? What is the "PAL packer files" please?

Do i have to follow with the mod guide?i already have the homebrew chanel and my wii was modified with a chip long time ago (more than ten years). thanks



#2719 EuroMIX

EuroMIX
  • 86 posts

Posted June 11, 2018 - 01:47 PM

Download the files listed under "DLC Packer 2.1 PAL version" on the first page. These ones: http://keepitfishy.c...p?540ba330a51ad

 

The regions have some differences in how they handle DLC so you can't really just pack with one when your system is set up for another. Use the PAL packing folders for your case, and remember to change the generations to match that region e.g. sZAE should always be sZAP; if you see that E, change it to a P.



#2720 giravolt

giravolt
  • 10 posts

Posted June 11, 2018 - 03:23 PM

Many thanks really...hope i will suceed one day. I didn't understand if I need to creat a sZFP folder or use the sZAP (wich already exists), i've tried both and didn't really work, but now i have an error message (in french) on the menu of RB3... it said (i translate)

"the license for the additional content has been removed from the console's memory. To use the additional content, download the additional content again"

do you have a






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users