Jump to content

Avatar

[How-To] Playing Customs on Wii


  • Please log in to reply
2149 replies to this topic

#2141 Alternity

Alternity
  • 448 posts

Posted March 25, 2017 - 01:17 AM

 

How is the meta folder supposed to be organized, or what else might be causing this issue?  The song folder is there, and my meta folder looks like

 

content >> songs >>songs.dta  /  (songname) >> songnameprev.mogg   /  gen >> songname_keep.pngwii

The included example song should show you what you're looking for.



#2142 toe jam

toe jam
  • 2 posts

Posted March 25, 2017 - 10:08 AM

 

StackOverflow0x:

 

I'm new on dolphin. I have a wii and i'm absolutely fan of guitar hero games and rock band games. I owe almost all of them.

 

I have been for couple of weeks studing a lot about how to play customs songs on rock band 3 (dolphin). I have achieved a lot. Even I have achived to play with a real wii harmonix keytar (keyboard) on rock band 3, although in many places are saying that this is imposible because dolphin doesn't emulate keytar.

 

Well, I tried with your gecko codes for rock band 3. The most important to me are working without problems (fast start, crowmeter, autoplay...) but the most important to me (no venues) doesn't work, and I have no idea.

 

I want to get rid of the venues because sometimes  causes low speed, and it is very anoying. I need help. I tried with concentrion mode v2, no venues, venues never appear, but always there is a background when the song start to play.

 

Please, any idea?



#2143 edisleado

edisleado
  • 4 posts

Posted March 25, 2017 - 02:23 PM

There's an old executable out there (maybe on an old Google Code site) for unpacking BIN files from store-downloaded DLC. Then you could transfer your BIN DLC to app DLC. Unfortunately, it doesn't work for post-RB3 DLC. I'd like to figure it out, but Dolphin is unable to emulate the SD card functionality properly for me to investigate.

 

Thanks for the response, Stack! I'll take a look for it...

 

I think I've got my emulated NAND working (I'm using neek2o, to be exact), but I'm having trouble getting any songs to show up in Rock Band 3. I got used to the flow of adding songs via SD, so I didn't think I'd have any trouble doing the equivalent with the NAND setup, but I've had no luck so far.

 

I made sure to put the APP files in the correct NAND folder, added the 26 APP file and all the title and tik files as per the original post, but I can't see any songs in-game. Can anyone help me figure out what's going wrong here? Thanks!



#2144 Alternity

Alternity
  • 448 posts

Posted March 25, 2017 - 05:27 PM

 

StackOverflow0x:

 

I'm new on dolphin. I have a wii and i'm absolutely fan of guitar hero games and rock band games. I owe almost all of them.

 

I have been for couple of weeks studing a lot about how to play customs songs on rock band 3 (dolphin). I have achieved a lot. Even I have achived to play with a real wii harmonix keytar (keyboard) on rock band 3, although in many places are saying that this is imposible because dolphin doesn't emulate keytar.

 

Well, I tried with your gecko codes for rock band 3. The most important to me are working without problems (fast start, crowmeter, autoplay...) but the most important to me (no venues) doesn't work, and I have no idea.

 

I want to get rid of the venues because sometimes  causes low speed, and it is very anoying. I need help. I tried with concentrion mode v2, no venues, venues never appear, but always there is a background when the song start to play.

 

Please, any idea?

 

​You still can't emulate the keyboard: You are not emulating it... you are using the real deal. All wii hardware works with dolphin (Except microphones.. but they are working on it right now)

​There are 3 ways to get rid of them: Either use the always show video venue cheat; or enable all-instruments in-game. All-instruments mode forces video venue to load 100% of the time. Playing online (Not just being online; playing with other people) also forces the video venue.



#2145 moc_os

moc_os
  • 49 posts

Posted March 25, 2017 - 08:56 PM

anybody got rb3 on vwii working well? i got my customs on there, i can play, but it seems like at regular intervals i miss notes when i clearly know i didn't. 

 

i play on drums with an ekit. never had trouble on the wii, but on the wii u i miss the easiest of notes and can't even gold star the easiest of songs, even songs that i can FC. some songs align to the skip perfectly, others seem more random. like on one song, every 14 measures i would miss on the second beat.



#2146 StackOverflow0x

StackOverflow0x

    Wii Guy

  • 1,198 posts

Posted Yesterday

​You still can't emulate the keyboard: You are not emulating it... you are using the real deal. All wii hardware works with dolphin (Except microphones.. but they are working on it right now)

​There are 3 ways to get rid of them: Either use the always show video venue cheat; or enable all-instruments in-game. All-instruments mode forces video venue to load 100% of the time. Playing online (Not just being online; playing with other people) also forces the video venue.

Yeah, I thought the latest Dolphin allows for real USB hardware to be used natively - including microphones. I haven't tried it, but confirmation would be nice.

 

As for the always venue cheat, have you tried this version of the cheat?

$Always Video Venues 2
042280A4 FC200090
*Assembly edit to always enable video venues

 

Thanks for the response, Stack! I'll take a look for it...

 

I think I've got my emulated NAND working (I'm using neek2o, to be exact), but I'm having trouble getting any songs to show up in Rock Band 3. I got used to the flow of adding songs via SD, so I didn't think I'd have any trouble doing the equivalent with the NAND setup, but I've had no luck so far.

 

I made sure to put the APP files in the correct NAND folder, added the 26 APP file and all the title and tik files as per the original post, but I can't see any songs in-game. Can anyone help me figure out what's going wrong here? Thanks!

When you're adding the APP files, does that include the TMD file for that content folder? Have you tried also installing the respective WADs for the content generations instead of just adding the ticket files? I think that might be a reliable option.

 

anybody got rb3 on vwii working well? i got my customs on there, i can play, but it seems like at regular intervals i miss notes when i clearly know i didn't. 

 

i play on drums with an ekit. never had trouble on the wii, but on the wii u i miss the easiest of notes and can't even gold star the easiest of songs, even songs that i can FC. some songs align to the skip perfectly, others seem more random. like on one song, every 14 measures i would miss on the second beat.

That certainly sounds odd. Sure it doesn't have anything to do with your audio sync settings? Otherwise, is the game just notably skip every once in a while?



#2147 Alternity

Alternity
  • 448 posts

Posted Yesterday

Yeah, I thought the latest Dolphin allows for real USB hardware to be used natively - including microphones. I haven't tried it, but confirmation would be nice.

 

I don't know about the new driver thing; I haven't tested that; but the Zadig workaround they had before worked with everything so far except microphones. I played with an MPA (all 3 switches works) and a friend tried with the official wii keyboard and it also worked.



#2148 DB744

DB744
  • 75 posts
  • Location
    Cleveland, OH

Posted Yesterday

The "Usage" link in Rockbiink is broken.

Also, I've been encountering an issue with Rock Biink that I've never had before. What if the resulting .bin from packing after the whole RockBiink process ends up significantly larger than before?
"We are the voice of Aiur."

#2149 StackOverflow0x

StackOverflow0x

    Wii Guy

  • 1,198 posts

Posted Today

The "Usage" link in Rockbiink is broken.

Also, I've been encountering an issue with Rock Biink that I've never had before. What if the resulting .bin from packing after the whole RockBiink process ends up significantly larger than before?

 

Oh yeah, it's probably been broken ever since we changed forum software, which was quite a while ago. I'll make sure to include that in the next update.

 

As for the file size issue, is the .bik file smaller than the source file? What is happening between when RockBiink outputs its file and you pack a bin? You're not leaving in the old audio file in there are you?



#2150 toe jam

toe jam
  • 2 posts

Posted Today

Yeah, I thought the latest Dolphin allows for real USB hardware to be used natively - including microphones. I haven't tried it, but confirmation would be nice.

 

As for the always venue cheat, have you tried this version of the cheat?

$Always Video Venues 2
042280A4 FC200090
*Assembly edit to always enable video venues

When you're adding the APP files, does that include the TMD file for that content folder? Have you tried also installing the respective WADs for the content generations instead of just adding the ticket files? I think that might be a reliable option.

 

That certainly sounds odd. Sure it doesn't have anything to do with your audio sync settings? Otherwise, is the game just notably skip every once in a while?

I got it. I used the concentration mode v2 042282AC 3C608000, and now works. Before I tried to use another code.

 

No videos, only a nice black background, and everythings is faster without lags.

 

Do you know what would be absolutely fantastic?. No background in any place. Only a black screen with the options. My computer - a fairly nice one - lags in the songs selection screen, and in the other menu screen because the background. Very annoying.

 

And I use dx9 with dolphin 4.0. Forgot Dx11 and dolphin 5.0.

 

Yes, I use my harmonix keytar with dolphin 4.0 and zadig drivers. Very happy with it.






3 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users


    Bing (1)